IBM DB2 설치 요구 사항

Linux, UNIX 및 Windows용 IBM DB2 Universal Database, IBM Cloudscape 또는 Apache Derby에 연결하려면 PHP를 실행 중인 동일한 컴퓨터에 IBM DB2 Universal Database 클라이언트를 설치해야 합니다. 확장은 DB2 버전 8.2로 개발 및 테스트되었습니다.

z/OS 또는 iSeries용 IBM DB2 Universal Database에 연결하려면 IBM DB2 Connect 또는 이에 상응하는 DRDA 게이트웨이 소프트웨어도 필요합니다.


Linux 또는 Unix의 요구 사항

PHP 실행 파일 또는 SAPI를 호출하는 사용자는 이러한 함수에 액세스하기 전에 DB2 인스턴스를 지정해야 합니다. ibm_db2.instance_name 구성 옵션을 사용하여 php.ini에서 DB2 인스턴스의 이름을 설정하거나 PHP 실행 파일을 호출하기 전에 DB2 인스턴스 프로파일을 소싱할 수 있습니다.

예를 들어 /home/db2inst1/db2inst1이라는 DB2 인스턴스를 만든 경우 php.ini에 다음 줄을 추가할 수 있습니다.

ibm_db2.instance_name=db2inst1
                

php.ini에서 이 옵션을 설정하지 않은 경우 다음 명령을 실행하여 환경 변수를 수정하여 DB2에 대한 액세스를 활성화해야 합니다.

bash$ source /home/db2inst1/sqllib/db2profile
                

PHP 사용 웹 서버가 이러한 함수에 액세스할 수 있도록 하려면 php.ini에서 ibm_db2.instance_name 구성 옵션을 설정하거나 웹 서버 시작 스크립트(일반적으로 /etc/init.d/httpd 또는 /etc/init.d/apache).