pthreads 설치 요구사항

pthreads를 사용하려면 ZTS(Zend Thread Safety)가 활성화된 PHP 빌드가 필요합니다(--enable-zts 또는 PHP 8.0.0 이전의 비 Windows 시스템에서는 --enable-maintainer-zts).

주의 Zend Thread Safety는 빌드 후에 활성화할 수 없습니다. 빌드 시간 구성 옵션입니다.

pthreads는 Windows(redhat의 pthread-w32 프로젝트 사용)를 포함하여 작동하는 Posix Threads 헤더(pthread.h) 및 PHP의 ZTS 빌드가 있는 모든 곳에서 빌드해야 합니다.