RRDtool 설치 요구사항

PECL/rrd를 사용하려면 먼저 librrd를 설치해야 합니다. 가장 일반적인 옵션은 좋아하는 Linux 배포판의 librrd-dev 패키지를 사용하는 것입니다. PECL/rrd는 librrd 1.4.3에서 테스트되었으며, 이전 또는 최신 버전이 작동하거나 작동하지 않을 수 있습니다.

경고 Librrd 및 따라서 확장 자체는 대부분 스레드로부터 안전하지 않습니다. librrd에는 많은 전역 및 공유 상태가 있습니다. Apache2 mpm 작업자와 같은 다중 스레드 환경에서 이 확장을 사용하는 것은 위험할 수 있습니다. 병렬 요청이 많은 경우 하나의 요청이 실행 중인 다른 요청의 일부 전역 librrd 상태를 변경할 수 있습니다.