Support Vector Machine(SVM) 설치 요구사항

Libsvm 자체가 필요하며 일부 패키지 관리를 통해 사용할 수 있습니다. RPM 기반 시스템의 경우 libsvm-devel 또는 Debian 기반 시스템의 경우 libsvm-dev입니다. 또는 웹 사이트에서 직접 사용할 수 있습니다. » 공식 웹사이트에서 설치하는 경우 패키지가 자동으로 설치되지 않으므로 몇 가지 단계를 수행해야 합니다. 예를 들어 최신 버전이 3.1이라고 가정합니다.

wget http://www.csie.ntu.edu.tw/~cjlin/cgi-bin/libsvm.cgi?+http://www.csie.ntu.edu.tw/~cjlin/libsvm+tar.gz
tar xvzf libsvm-3.1.tar.gz
cd libsvm-3.1
make lib
cp libsvm.so.1 /usr/lib
ln -s libsvm.so.1 libsvm.so
ldconfig
ldconfig --print | grep libsvm
                

이 마지막 단계는 libsvm이 설치되었음을 보여야 합니다.